blob: 042938b88ef0bdea86946f5db35b97ee426444af [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A library on top of GStreamer for building an RTSP server"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-rtsp-server/"
3SECTION = "multimedia"
4LICENSE = "LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d"
6
7DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base"
8
9PNREAL = "gst-rtsp-server"
10
11SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
13 file://gtk-doc-tweaks.patch \
14 "
15
Brad Bishop15ae2502019-06-18 21:44:24 -040016SRC_URI[md5sum] = "adc4460239ec2eccf58ad9752ce53bfd"
17SRC_URI[sha256sum] = "198e9eec1a3e32dc810d3fbf3a714850a22c6288d4a5c8e802c5ff984af03f19"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19S = "${WORKDIR}/${PNREAL}-${PV}"
20
21inherit autotools pkgconfig upstream-version-is-even gobject-introspection gtk-doc
22
23EXTRA_OECONF = "--disable-examples --disable-tests"
24
25# Starting with 1.8.0 gst-rtsp-server includes dependency-less plugins as well
26LIBV = "1.0"
27require gst-plugins-package.inc
28
29delete_pkg_m4_file() {
30 # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection
31 rm "${S}/common/m4/pkg.m4" || true
32}
33
34do_configure[prefuncs] += " delete_pkg_m4_file"