blob: 244d9e204ee2360d40179c78f0ed576e6bb50d40 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Name Service Switch module for resolving the local hostname"
2DESCRIPTION = "plugin for the GNU Name Service Switch (NSS) functionality of \
3the GNU C Library (glibc) providing host name resolution for the locally \
4configured system hostname as returned by gethostname(2)."
5HOMEPAGE = "http://0pointer.de/lennart/projects/nss-myhostname/"
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
8
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05009SRC_URI = "http://0pointer.de/lennart/projects/nss-myhostname/nss-myhostname-${PV}.tar.gz \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050010 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12SRC_URI[md5sum] = "d4ab9ac36c053ab8fb836db1cbd4a48f"
13SRC_URI[sha256sum] = "2ba744ea8d578d1c57c85884e94a3042ee17843a5294434d3a7f6c4d67e7caf2"
14
15inherit autotools distro_features_check
16
Brad Bishop15ae2502019-06-18 21:44:24 -040017COMPATIBLE_HOST_libc-musl = 'null'
18
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019# The systemd has its own copy of nss-myhostname
20CONFLICT_DISTRO_FEATURES = "systemd"
21
22pkg_postinst_${PN} () {
23 sed -e '/^hosts:/s/\s*\<myhostname\>//' \
24 -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 myhostname \3\4\5/' \
25 -i $D${sysconfdir}/nsswitch.conf
26}
27
28pkg_prerm_${PN} () {
29 sed -e '/^hosts:/s/\s*\<myhostname\>//' \
30 -e '/^hosts:/s/\s*myhostname//' \
31 -i $D${sysconfdir}/nsswitch.conf
32}