blob: dec60fcc9bb61e5810e0dcc84367fa3b8ec8cd6b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
Brad Bishop15ae2502019-06-18 21:44:24 -040010SRCREV = "63d097cc46142157931682fed076b5407757a0bd"
Brad Bishop19323692019-04-05 15:28:33 -040011PV = "2.3.1+git${SRCPV}"
12
Brad Bishopd89cb5f2019-04-10 09:02:41 -040013SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
14 file://0001-utils-Ensure-stdout-stderr-are-flushed.patch \
15 file://0002-use-process-groups-when-spawning.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040016 file://0003-utils-Ensure-pipes-are-read-after-exit.patch \
17 file://0004-utils-ensure-child-can-be-session-leader.patch \
18"
Brad Bishopd89cb5f2019-04-10 09:02:41 -040019
Brad Bishop19323692019-04-05 15:28:33 -040020S = "${WORKDIR}/git"
21
22FILES_${PN} = "${bindir}/ptest-runner"
23
24EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
25
26do_compile () {
27 oe_runmake
28}
29
30do_install () {
31 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
32}