blob: 38e270c03646d7ec35339266109a59b18f74cca2 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Tiny XML Library"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
4HOMEPAGE = "https://www.msweet.org/mxml/"
5BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues"
6
Andrew Geissler5082cc72023-09-11 08:41:39 -04007SRC_URI = "git://github.com/michaelrsweet/mxml.git;branch=master;protocol=https"
Patrick Williams92b42cb2022-09-03 06:53:57 -05008SRCREV = "fd47c7d115191c8a6bce2c781ffee41e179530f2"
9S = "${WORKDIR}/git"
10
Patrick Williams169d7bc2024-01-05 11:33:25 -060011# Package does not support out of tree builds.
12inherit autotools-brokensep
Patrick Williams92b42cb2022-09-03 06:53:57 -050013
14PACKAGECONFIG ??= "threads"
15PACKAGECONFIG[threads] = "--enable-threads,--disable-threads"
16
Patrick Williams92b42cb2022-09-03 06:53:57 -050017# MXML uses autotools but it explicitly states it does not support autoheader.
18EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
19
20do_configure:prepend() {
21 # Respect optimization CFLAGS specified by OE.
22 sed -e 's/-Os -g//' -i ${S}/configure.ac
23
24 # Enable verbose compilation output. This is required for extra QA checks to work.
25 sed -e '/.SILENT:/d' -i ${S}/Makefile.in
26}
27
28do_install() {
29 # Package uses DSTROOT instread of standard DESTDIR to specify install location.
30 oe_runmake install DSTROOT=${D}
31}