blob: 494e609319ef0aebf3781f033c9926ef9ccd360d [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The extensible, standards compliant build backend used by Hatch"
2HOMEPAGE = "https://hatch.pypa.io/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9"
5
6inherit pypi python_hatchling
7
Andrew Geissler3eeda902023-05-19 10:14:02 -05008DEPENDS += "python3-pluggy-native python3-pathspec-native python3-packaging-native python3-editables-native python3-trove-classifiers-native"
Andrew Geissler517393d2023-01-13 08:55:19 -06009DEPENDS:remove:class-native = "python3-hatchling-native"
10
Patrick Williams169d7bc2024-01-05 11:33:25 -060011SRC_URI[sha256sum] = "5c086772357a50723b825fd5da5278ac7e3697cdf7797d07541a6c90b6ff754c"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13do_compile:prepend() {
14 export PYTHONPATH=src
15}
16
17BBCLASSEXTEND = "native nativesdk"