blob: 3b81afd7c077152707d582de9a3863b8d3560028 [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001SUMMARY = "Small image capable of booting a device with custom install scripts, \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00002adding a second rootfs, used for testing."
3
4# use -testfs live-install scripts
5PACKAGE_INSTALL = "initramfs-live-boot initramfs-live-install-testfs initramfs-live-install-efi-testfs busybox udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
6
7# Do not pollute the initrd image with rootfs features
8IMAGE_FEATURES = ""
9
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010IMAGE_NAME_SUFFIX ?= ""
11IMAGE_LINGUAS = ""
12
13LICENSE = "MIT"
14
15IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
16inherit core-image
17
18IMAGE_ROOTFS_SIZE = "8192"
19IMAGE_ROOTFS_EXTRA_SPACE = "0"
20BAD_RECOMMENDATIONS += "busybox-syslog"
21
22# Use the same restriction as initramfs-live-install-testfs
23COMPATIBLE_HOST = "(i.86|x86_64).*-linux"