blob: 4b20e1ed9a0fdf90c5bcc0fb911c714be508b417 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "kexecboot linux-as-bootloader"
2DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec."
3HOMEPAGE = "http://kexecboot.org"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6PV = "0.6+git${SRCPV}"
7S = "${WORKDIR}/git"
8SRC_URI = "git://github.com/kexecboot/kexecboot.git"
Brad Bishop19323692019-04-05 15:28:33 -04009SRC_URI_append_libc-klibc = " file://0001-kexecboot-Use-new-reboot-API-with-klibc.patch "
10
11SRCREV = "7409a1e0aaea61af87c4eca0149cec18a9f58ab6"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012inherit autotools
13
14EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
15
16do_install () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017 install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018 install -d ${D}/proc
19 install -d ${D}/mnt
20 install -d ${D}/dev
21 install -d ${D}/sys
22}
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys"
27
28pkg_postinst_${PN} () {
29 ln -sf ${bindir}/kexecboot $D/init
30}
31
32BBCLASSEXTEND = "klibc"