blob: 90051a319a5205ae8e4312aff9bc70d2ab7ab0c0 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Dibbler DHCPv6 client"
2DESCRIPTION = "Dibbler is a portable DHCPv6 implementation. It supports stateful as well as stateless autoconfiguration for IPv6."
3HOMEPAGE = "http://klub.com.pl/dhcpv6"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3"
7
8SRCREV = "c4b0ed52e751da7823dd9a36e91f93a6310e5525"
9
10SRC_URI = "git://github.com/tomaszmrugalski/dibbler \
11 file://dibbler_fix_getSize_crash.patch \
Brad Bishop19323692019-04-05 15:28:33 -040012 file://0001-linux-port-Rename-pthread_mutex_t-variable-lock.patch \
13 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014PV = "1.0.1+1.0.2RC1+git${SRCREV}"
15
16S = "${WORKDIR}/git"
17
18PACKAGECONFIG ??= "debug bind-reuse resolvconf dns-update"
19
20PACKAGECONFIG[debug] = "--enable-debug,,,"
21PACKAGECONFIG[efence] = "--enable-efence,,,"
22PACKAGECONFIG[bind-reuse] = "--enable-bind-reuse,,,"
23PACKAGECONFIG[dst-addr-filter] = "--enable-dst-addr-check,,,"
24PACKAGECONFIG[resolvconf] = "--enable-resolvconf,,,"
25PACKAGECONFIG[dns-update] = "--enable-dns-update,,,"
26PACKAGECONFIG[auth] = "--enable-auth,,,"
27PACKAGECONFIG[gtest] = "--enable-gtest-static,,,"
28
29inherit autotools
30
31DEPENDS += "flex-native"
32
33PACKAGES =+ "${PN}-requestor ${PN}-client ${PN}-relay ${PN}-server"
34
35FILES_${PN}-client = "${sbindir}/${PN}-client"
36FILES_${PN}-relay = "${sbindir}/${PN}-relay"
37FILES_${PN}-requestor = "${sbindir}/${PN}-requestor"
38FILES_${PN}-server = "${sbindir}/${PN}-server"