blob: 46c66a1b2c929eb24645336cc9a682b686d8d0ec [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
2HOMEPAGE = "http://www.chronox.de/libkcapi.html"
3LICENSE = "BSD | GPL-2.0"
Brad Bishop19323692019-04-05 15:28:33 -04004LIC_FILES_CHKSUM = "file://COPYING;md5=14d5a68b28755c04ebdba226e888b157"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005
6DEPENDS = "libtool"
7
8S = "${WORKDIR}/git"
Brad Bishop19323692019-04-05 15:28:33 -04009SRCREV = "3c56934f44a8f5a1257c342942e6e034fc6f20be"
10PV = "1.1.4+git${SRCPV}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011SRC_URI = " \
12 git://github.com/smuellerDD/libkcapi.git \
13"
14
15inherit autotools
16
17PACKAGECONFIG ??= ""
Brad Bishop19323692019-04-05 15:28:33 -040018PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
20
21do_install_append() {
22 # bindir contains testapp and apps. However it is always created, even
23 # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
24 rmdir --ignore-fail-on-non-empty ${D}${bindir}
Brad Bishop19323692019-04-05 15:28:33 -040025
26 # Remove the generated binary checksum files
27 rm -f ${D}${bindir}/.*.hmac
28 rm -f ${D}${libdir}/.*.hmac
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029}
30
31CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare"