blob: e3ed9c6a17dd321b97dbf548a53db325995259cb [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A fast JSON parser/generator for C++ with both SAX/DOM style API"
2HOMEPAGE = "http://rapidjson.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://license.txt;md5=ba04aa8f65de1396a7e59d1d746c2125"
6
Brad Bishop19323692019-04-05 15:28:33 -04007SRC_URI = "git://github.com/miloyip/rapidjson.git;nobranch=1 \
8 file://0001-CMake-remove-hardcoded-CMAKECONFIG_INSTALL_DIR-path.patch"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010SRCREV = "6a905f9311f82d306da77bd963ec5aa5da07da9c"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011
12PV = "1.1.0+git${SRCPV}"
13
14S = "${WORKDIR}/git"
15
16inherit cmake
17
Brad Bishop19323692019-04-05 15:28:33 -040018EXTRA_OECMAKE += "-DRAPIDJSON_BUILD_DOC=OFF -DRAPIDJSON_BUILD_TESTS=OFF -DRAPIDJSON_BUILD_EXAMPLES=OFF -DLIB_INSTALL_DIR:STRING=${libdir}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019
20# RapidJSON is a header-only C++ library, so the main package will be empty.
21
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022ALLOW_EMPTY_${PN} = "1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023
24BBCLASSEXTEND = "native nativesdk"