blob: f75ac6f81ca3d8c21f7b705d30313eab6709247e [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Inspect and manipulate eBPF programs and maps"
2DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \
3of eBPF programs and maps."
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
6DEPENDS = "binutils elfutils"
7PROVIDES = "virtual/bpftool"
8
9inherit bash-completion kernelsrc kernel-arch
10
11do_populate_lic[depends] += "virtual/kernel:do_patch"
12
13EXTRA_OEMAKE = "-C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
14
15do_configure[depends] += "virtual/kernel:do_shared_workdir"
16
Andrew Geissler1548c072019-02-22 16:03:50 -060017COMPATIBLE_HOST_libc-musl = 'null'
18
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019do_compile() {
20 oe_runmake
21}
22
23do_install() {
24 oe_runmake DESTDIR=${D} install
25}
26
27PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29python do_package_prepend() {
Brad Bishop19323692019-04-05 15:28:33 -040030 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031}
32
33B = "${WORKDIR}/${BPN}-${PV}"