blob: b1b150a7d0f5ffbfe3adb6dc3c0de25c268774b9 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "network auditing tool"
2DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing.\nGui support via appending to IMAGE_FEATURES x11-base in local.conf"
3SECTION = "security"
4LICENSE = "GPL-2.0"
5
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=1489288f46af415fadc4e8b6345ab9f4"
7
8SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \
9 file://nmap-redefine-the-python-library-dir.patch \
10 file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \
Andrew Geissler1548c072019-02-22 16:03:50 -060011 file://0001-include-time.h-for-time-structure-definition.patch \
12 file://0002-Fix-building-with-libc.patch \
13 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
15SRC_URI[md5sum] = "84eb6fbe788e0d4918c2b1e39421bf79"
16SRC_URI[sha256sum] = "847b068955f792f4cc247593aca6dc3dc4aae12976169873247488de147a6e18"
17
18inherit autotools-brokensep pkgconfig pythonnative
19
20PACKAGECONFIG ?= "ncat nping ndiff pcap"
21
22PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap"
Andrew Geissler1548c072019-02-22 16:03:50 -060023PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpcre"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl"
25PACKAGECONFIG[ssh2] = "--with-openssh2=${STAGING_LIBDIR}/.., --without-openssh2, libssh2, libssh2"
26PACKAGECONFIG[libz] = "--with-libz=${STAGING_LIBDIR}/.., --without-libz, zlib, zlib"
27
28#disable/enable packages
29PACKAGECONFIG[nping] = ",--without-nping,"
30PACKAGECONFIG[ncat] = ",--without-ncat,"
31PACKAGECONFIG[ndiff] = ",--without-ndiff,python"
32PACKAGECONFIG[update] = ",--without-nmap-update,"
33
34EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included"
35
36# zenmap needs python-pygtk which has been removed
37# it also only works with python2
38# disable for now until py3 is supported
39EXTRA_OECONF += "--without-zenmap"
40
41export PYTHON_SITEPACKAGES_DIR
42
43do_configure() {
44 autoconf
Brad Bishop19323692019-04-05 15:28:33 -040045 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
46 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080047 oe_runconf
48}
49
Andrew Geissler1548c072019-02-22 16:03:50 -060050FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR} ${datadir}/ncat"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080051
52RDEPENDS_${PN} = "python"