blob: 3fd91e958f0772c6858b644c1490c970c135b99a [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics. "
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08"
4
5DEPENDS = "intltool-native libusb1 libgudev glib-2.0 dbus-glib polkit"
6
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007SRC_URI = " \
8 http://upower.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
9 file://0001-linux-lower-severity-of-unhandled-action-messages.patch \
10"
Brad Bishop316dfdd2018-06-25 12:45:53 -040011SRC_URI[md5sum] = "236bb439d9ff1151450b3d8582399532"
12SRC_URI[sha256sum] = "24bcc2f6ab25a2533bac70b587bcb019e591293076920f5b5e04bdedc140a401"
13
Brad Bishop19323692019-04-05 15:28:33 -040014inherit autotools pkgconfig gettext gobject-introspection systemd distro_features_check
15
16REQUIRED_DISTRO_FEATURES = "polkit"
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
18PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
19PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"
20PACKAGECONFIG[systemd] = "--with-systemdutildir=${systemd_unitdir} --with-systemdsystemunitdir=${systemd_system_unitdir}, \
21 --without-systemdutildir --without-systemdsystemunitdir,systemd"
22
23EXTRA_OECONF = " --with-backend=linux"
24
25SYSTEMD_SERVICE_${PN} = "upower.service"
26# don't start on boot by default - dbus does that on demand
27SYSTEMD_AUTO_ENABLE = "disable"
28
29do_configure_prepend() {
30 sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
31 sed -i -e 's: doc : :g' ${S}/Makefile.am
32}
33
34RDEPENDS_${PN} += "dbus"
35RRECOMMENDS_${PN} += "pm-utils"
36FILES_${PN} += "${datadir}/dbus-1/ \
37 ${datadir}/polkit-1/ \
38 ${base_libdir}/udev/* \
39"