blob: 9aa8d2ae73b678f73e04dde365cafbcb345e4ffb [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "C implementation of createrepo."
2HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009 "
10
Brad Bishop19323692019-04-05 15:28:33 -040011PV = "0.12.1"
12SRCREV = "7744554ddef7c5be2cd7fbcac49c8b24ce60ef88"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
14S = "${WORKDIR}/git"
15
16DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
17DEPENDS_append_class-native = " file-replacement-native"
18
19inherit cmake pkgconfig bash-completion distutils3-base
20
Brad Bishop19323692019-04-05 15:28:33 -040021EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023BBCLASSEXTEND = "native nativesdk"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024
25# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
26do_install_append_class-native() {
27 create_wrapper ${D}/${bindir}/createrepo_c \
28 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
29}
30
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031do_install_append_class-nativesdk() {
32 create_wrapper ${D}/${bindir}/createrepo_c \
33 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
34 rm -rf ${D}/etc
35}