blob: 892b8e8733a569411c4ba23342a6fcf6049fff14 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001From 46d2c2f8fecad85baeed9fe211f5285820220442 Mon Sep 17 00:00:00 2001
Brad Bishop6e60e8b2018-02-01 10:27:11 -05002From: James Cowgill <james410@cowgill.org.uk>
3Date: Mon, 5 Jan 2015 15:16:58 +0000
Brad Bishop19323692019-04-05 15:28:33 -04004Subject: [PATCH] Ignore differences between mips machine identifiers
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005
6Little endian binaries actually use EM_MIPS so you can't tell the endianness
7from the elf machine id. Also, the EM_MIPS_RS3_LE machine is dead anyway (the
8kernel will not load binaries containing it).
9
10Signed-off-by: James Cowgill <james410@cowgill.org.uk>
Brad Bishopa5c52ff2018-11-23 10:55:50 +130011Upstream-Status: Pending [from debian]
12Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Brad Bishop19323692019-04-05 15:28:33 -040013
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014---
15 backends/mips_init.c | 6 +-----
16 1 file changed, 1 insertion(+), 5 deletions(-)
17
Brad Bishop19323692019-04-05 15:28:33 -040018diff --git a/backends/mips_init.c b/backends/mips_init.c
19index 975c04e..8482e7f 100644
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020--- a/backends/mips_init.c
21+++ b/backends/mips_init.c
Brad Bishop19323692019-04-05 15:28:33 -040022@@ -45,11 +45,7 @@ mips_init (Elf *elf __attribute__ ((unused)),
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023 return NULL;
24
25 /* We handle it. */
26- if (machine == EM_MIPS)
27- eh->name = "MIPS R3000 big-endian";
28- else if (machine == EM_MIPS_RS3_LE)
29- eh->name = "MIPS R3000 little-endian";
30-
31+ eh->name = "MIPS";
32 mips_init_reloc (eh);
33 HOOK (eh, reloc_simple_type);
34 HOOK (eh, return_value_location);