blob: ff6820851fe53f3ba496370ffeefba5807eddb36 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Libcomps is alternative for yum.comps library (which is for managing rpm package groups)."
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "git://github.com/rpm-software-management/libcomps.git \
6 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
7 file://0002-Set-library-installation-path-correctly.patch \
8 file://0001-Make-__comps_objmrtree_all-static-inline.patch \
Brad Bishop19323692019-04-05 15:28:33 -04009 file://0001-Add-crc32.c-to-sources-list.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 "
11
Brad Bishop19323692019-04-05 15:28:33 -040012PV = "0.1.10"
13SRCREV = "86a82fcd155c27092340d15a34f5c75c4da88243"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014
15S = "${WORKDIR}/git"
16
17inherit cmake distutils3-base
18
19DEPENDS += "libxml2 expat libcheck"
20
21EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
22OECMAKE_SOURCEPATH = "${S}/libcomps"
23
24BBCLASSEXTEND = "native nativesdk"
25