blob: db1bd9fc5b8c475f90943b6bebcf4e104c3d102d [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://include/pub_tool_basics.h;beginline=6;endline=29;md5=d4de0407239381463cf01dd276d7c22e \
7 file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
10X11DEPENDS = "virtual/libx11"
11DEPENDS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)} \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
13 "
14
15SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
16 file://fixed-perl-path.patch \
17 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
18 file://run-ptest \
19 file://0004-Fix-out-of-tree-builds.patch \
20 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
21 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
22 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
23 file://avoid-neon-for-targets-which-don-t-support-it.patch \
24 file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \
25 file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \
26 file://0001-str_tester.c-Limit-rawmemchr-test-to-glibc.patch \
27 file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \
28 file://0002-context-APIs-are-not-available-on-musl.patch \
29 file://0003-correct-include-directive-path-for-config.h.patch \
30 file://0004-pth_atfork1.c-Define-error-API-for-musl.patch \
31 file://0005-tc20_verifywrap.c-Fake-__GLIBC_PREREQ-with-musl.patch \
32 file://0006-pth_detached3.c-Dereference-pthread_t-before-adding-.patch \
33 file://0001-memcheck-arm64-Define-__THROW-if-not-already-defined.patch \
34 file://0002-memcheck-x86-Define-__THROW-if-not-defined.patch \
35 file://0003-tests-seg_override-Replace-__modify_ldt-with-syscall.patch \
36 file://0001-fix-opcode-not-supported-on-mips32-linux.patch \
37 file://0001-Guard-against-__GLIBC_PREREQ-for-musl-libc.patch \
38 file://0001-Make-local-functions-static-to-avoid-assembler-error.patch \
Brad Bishop19323692019-04-05 15:28:33 -040039 file://0001-tests-amd64-Do-not-clobber-rsp-register.patch \
40 file://0001-Fix-dependencies-between-libcoregrind-.a-and-m_main..patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041 "
42SRC_URI[md5sum] = "74175426afa280184b62591b58c671b3"
43SRC_URI[sha256sum] = "037c11bfefd477cc6e9ebe8f193bb237fe397f7ce791b4a4ce3fa1c6a520baa5"
44UPSTREAM_CHECK_REGEX = "valgrind-(?P<pver>\d+(\.\d+)+)\.tar"
45
46COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
47
48# valgrind supports armv7 and above
49COMPATIBLE_HOST_armv4 = 'null'
50COMPATIBLE_HOST_armv5 = 'null'
51COMPATIBLE_HOST_armv6 = 'null'
52
53# X32 isn't supported by valgrind at this time
54COMPATIBLE_HOST_linux-gnux32 = 'null'
55COMPATIBLE_HOST_linux-muslx32 = 'null'
56
57# Disable for some MIPS variants
58COMPATIBLE_HOST_mipsarchr6 = 'null'
59COMPATIBLE_HOST_linux-gnun32 = 'null'
60
Brad Bishop19323692019-04-05 15:28:33 -040061# Disable for powerpc64 with musl
62COMPATIBLE_HOST_libc-musl_powerpc64 = 'null'
63
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080064inherit autotools ptest multilib_header
65
66EXTRA_OECONF = "--enable-tls --without-mpicc"
67EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
68
69# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
70EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080071
72EXTRA_OEMAKE = "-w"
73
74CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
75
76# valgrind likes to control its own optimisation flags. It generally defaults
77# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
78# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
79# which fixes build path issue in DWARF.
80SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
81
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080082do_configure_prepend () {
83 rm -rf ${S}/config.h
84 sed -i -e 's:$(abs_top_builddir):$(pkglibdir)/ptest:g' ${S}/none/tests/Makefile.am
85 sed -i -e 's:$(top_builddir):$(pkglibdir)/ptest:g' ${S}/memcheck/tests/Makefile.am
86}
87
88do_install_append () {
89 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
90 oe_multilib_header valgrind/config.h
91}
92
Brad Bishopa5c52ff2018-11-23 10:55:50 +130093VALGRINDARCH ?= "${TARGET_ARCH}"
94VALGRINDARCH_aarch64 = "arm64"
95VALGRINDARCH_x86-64 = "amd64"
96VALGRINDARCH_x86 = "x86"
97VALGRINDARCH_mips = "mips32"
98VALGRINDARCH_mipsel = "mips32"
99VALGRINDARCH_mips64el = "mips64"
100VALGRINDARCH_powerpc = "ppc"
101VALGRINDARCH_powerpc64 = "ppc64"
102VALGRINDARCH_powerpc64el = "ppc64le"
103
104INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/valgrind/vgpreload_memcheck-${VALGRINDARCH}-linux.so"
105
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800106RDEPENDS_${PN} += "perl"
107
108# valgrind needs debug information for ld.so at runtime in order to
109# redirect functions like strlen.
110RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
111
112RDEPENDS_${PN}-ptest += " sed perl perl-module-file-glob"
113RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
114
115# One of the tests contains a bogus interpreter path on purpose.
116# Skip file dependency check
117SKIP_FILEDEPS_${PN}-ptest = '1'
118
119do_compile_ptest() {
120 oe_runmake check
121}
122
123do_install_ptest() {
124 chmod +x ${B}/tests/vg_regtest
125
126 # The test application binaries are not automatically installed.
127 # Grab them from the build directory.
128 #
129 # The regression tests require scripts and data files that are not
130 # copied to the build directory. They must be copied from the
131 # source directory.
132 saved_dir=$PWD
133 for parent_dir in ${S} ${B} ; do
134 cd $parent_dir
135
136 # exclude shell or the package won't install
137 rm -rf none/tests/shell* 2>/dev/null
138
139 subdirs="tests cachegrind/tests callgrind/tests drd/tests helgrind/tests massif/tests memcheck/tests none/tests"
140
141 # Get the vg test scripts, filters, and expected files
142 for dir in $subdirs ; do
143 find $dir | cpio -pvdu ${D}${PTEST_PATH}
144 done
145 cd $saved_dir
146 done
147
148 # clean out build artifacts before building the rpm
149 find ${D}${PTEST_PATH} \
150 \( -name "Makefile*" \
151 -o -name "*.o" \
152 -o -name "*.c" \
153 -o -name "*.S" \
154 -o -name "*.h" \) \
155 -exec rm {} \;
156
157 # needed by massif tests
158 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
159
160 # handle multilib
161 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
162}