blob: d3357f82de95f9601237f05b354a1398ded2a97f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
Brad Bishop19323692019-04-05 15:28:33 -040014GNOMEBASEBUILDCLASS = "meson"
15
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
18SRC_URI += "file://run-ptest \
Brad Bishop19323692019-04-05 15:28:33 -040019 file://insensitive-diff.patch"
20
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021SRC_URI[archive.md5sum] = "deb171a31a3ad76342d5195a1b5bbc7c"
22SRC_URI[archive.sha256sum] = "1d2b74cd63e8bd41961f2f8d952355aa0f9be6002b52c8aa7699d9f5da597c9d"
23
24DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
Brad Bishop19323692019-04-05 15:28:33 -040027PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
28
29GTKDOC_ENABLE_FLAG = "-Denable_docs=true"
30GTKDOC_DISABLE_FLAG = "-Denable_docs=false"
31
32GI_ENABLE_FLAG = "-Dgir=true"
33GI_DISABLE_FLAG = "-Dgir=false"
34
35EXTRA_OEMESON_append_class-nativesdk = " ${GI_DISABLE_FLAG}"
36
37EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GI_ENABLE_FLAG}', \
38 '${GI_DISABLE_FLAG}', d)} "
39
40EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_ENABLE_FLAG}', \
41 '${GTKDOC_DISABLE_FLAG}', d)} "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042
43LEAD_SONAME = "libpango-1.0*"
44LIBV = "1.8.0"
45
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080046FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
47FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
48
49RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts"
50
51RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
52 pango-module-basic-fc pango-module-arabic-lang"
53
Brad Bishop19323692019-04-05 15:28:33 -040054BBCLASSEXTEND = "native nativesdk"
55
56do_install_append () {
57 if [ "${PTEST_ENABLED}" != "1" ]; then
58 rm -rf ${D}${libexecdir}/installed-tests ${D}${datadir}/installed-tests
59 rmdir --ignore-fail-on-non-empty ${D}${libexecdir} ${D}${datadir}
60 fi
61}