blob: d54610412923af280aa4ffe9ca7a7399366a7556 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
Brad Bishop19323692019-04-05 15:28:33 -040011PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \
12 am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \
13 PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \
14"
15
16inherit autotools lib_package manpages python3native
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18DEPENDS = "liburcu util-linux"
19RDEPENDS_${PN}-bin = "python3-core"
20
21# For backwards compatibility after rename
22RPROVIDES_${PN} = "lttng2-ust"
23RREPLACES_${PN} = "lttng2-ust"
24RCONFLICTS_${PN} = "lttng2-ust"
25
26PE = "2"
27
28SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
29 file://lttng-ust-doc-examples-disable.patch \
Brad Bishop19323692019-04-05 15:28:33 -040030 file://0001-compat-work-around-broken-_SC_NPROCESSORS_CONF-on-MU.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050031 "
Brad Bishop19323692019-04-05 15:28:33 -040032
Brad Bishopf8caae32019-03-25 13:13:56 -040033SRC_URI[md5sum] = "ffcfa8c1ba9a52f002d240e936e9afa2"
34SRC_URI[sha256sum] = "9e8420f90d5f963f7aa32bc6d44adc1e491136f687c69ffb7a3075d33b40852b"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050035
36CVE_PRODUCT = "ust"
37
38PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
Brad Bishop19323692019-04-05 15:28:33 -040039PACKAGECONFIG[python3-agent] = "--enable-python-agent ${PYTHON_OPTION}, --disable-python-agent, python3, python3"
40
41FILES_${PN} += " ${PYTHON_SITEPACKAGES_DIR}/*"
42FILES_${PN}-staticdev += " ${PYTHON_SITEPACKAGES_DIR}/*.a"
43FILES_${PN}-dev += " ${PYTHON_SITEPACKAGES_DIR}/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050044
45do_install_append() {
46 # Patch python tools to use Python 3; they should be source compatible, but
47 # still refer to Python 2 in the shebang
48 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
49}