blob: 8975647daf439e3ae898fb3492f2601efbc267f5 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Version 5 of the Berkeley DB from Sleepycat
2#
3# At present this package only installs the DB code
4# itself (shared libraries, .a in the dev package),
5# documentation and headers.
6#
7# The headers have the same names as those as v3
8# of the DB, only one version can be used *for dev*
9# at once - DB3 and DB5 can both be installed on the
10# same system at the same time if really necessary.
11SECTION = "libs"
12SUMMARY = "Berkeley Database v5"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050013HOMEPAGE = "http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014LICENSE = "Sleepycat"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015RCONFLICTS_${PN} = "db3"
16
Brad Bishop316dfdd2018-06-25 12:45:53 -040017CVE_PRODUCT = "oracle_berkeley_db"
18CVE_VERSION = "11.2.${PV}"
19
Patrick Williamsc0f7c042017-02-23 20:41:17 -060020PR = "r1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021PE = "1"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060022
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024SRC_URI += "file://fix-parallel-build.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025 file://0001-atomic-Rename-local-__atomic_compare_exchange-to-avo.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026 file://0001-configure-Add-explicit-tag-options-to-libtool-invoca.patch \
27 file://sequence-type.patch \
Brad Bishop19323692019-04-05 15:28:33 -040028 file://0001-Fix-libc-compatibility-by-renaming-atomic_init-API.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030# We are not interested in official latest 6.x versions;
31# let's track what debian is using.
32UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/db5.3/"
Brad Bishop19323692019-04-05 15:28:33 -040033UPSTREAM_CHECK_REGEX = "db5\.3_(?P<pver>\d+(\.\d+)+).+\.orig"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034
35SRC_URI[md5sum] = "b99454564d5b4479750567031d66fe24"
36SRC_URI[sha256sum] = "e0a992d740709892e81f9d93f06daf305cf73fb81b545afe72478043172c3628"
37
Patrick Williamsc0f7c042017-02-23 20:41:17 -060038LIC_FILES_CHKSUM = "file://LICENSE;md5=ed1158e31437f4f87cdd4ab2b8613955"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040inherit autotools
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042# The executables go in a separate package - typically there
43# is no need to install these unless doing real database
44# management on the system.
45inherit lib_package
46
47PACKAGES =+ "${PN}-cxx"
48FILES_${PN}-cxx = "${libdir}/*cxx*so"
49
Patrick Williamsc124f4f2015-09-15 14:41:29 -050050# The dev package has the .so link (as in db3) and the .a's -
51# it is therefore incompatible (cannot be installed at the
52# same time) as the db3 package
53# sort out the .so since they do version prior to the .so
54SOLIBS = "-5*.so"
55FILES_SOLIBSDEV = "${libdir}/libdb.so ${libdir}/libdb_cxx.so"
56
57#configuration - set in local.conf to override
58# All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
59DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-verify --disable-compat185 --disable-sql"
60
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080061EXTRA_OECONF = "${DB5_CONFIG} --enable-shared --enable-cxx --with-sysroot STRIP=true"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062
Brad Bishopd7bf8c12018-02-25 22:55:05 -050063EXTRA_OEMAKE += "LIBTOOL='./${HOST_SYS}-libtool'"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060064
Brad Bishopd7bf8c12018-02-25 22:55:05 -050065EXTRA_AUTORECONF += "--exclude=autoheader -I ${S}/dist/aclocal -I${S}/dist/aclocal_java"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060066AUTOTOOLS_SCRIPT_PATH = "${S}/dist"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050067
68# Cancel the site stuff - it's set for db3 and destroys the
69# configure.
70CONFIG_SITE = ""
Brad Bishopd7bf8c12018-02-25 22:55:05 -050071
72oe_runconf_prepend() {
73 . ${S}/dist/RELEASE
74 # Edit version information we couldn't pre-compute.
75 sed -i -e "s/__EDIT_DB_VERSION_FAMILY__/$DB_VERSION_FAMILY/g" \
76 -e "s/__EDIT_DB_VERSION_RELEASE__/$DB_VERSION_RELEASE/g" \
77 -e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \
78 -e "s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" \
79 -e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \
80 -e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \
81 -e "s/__EDIT_DB_VERSION_FULL_STRING__/$DB_VERSION_FULL_STRING/g" \
82 -e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \
83 -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" ${S}/dist/configure
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084}
85
86do_compile_prepend() {
Patrick Williamsc0f7c042017-02-23 20:41:17 -060087 # Stop libtool adding RPATHs
Brad Bishopd7bf8c12018-02-25 22:55:05 -050088 sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' ${B}/${HOST_SYS}-libtool
Patrick Williamsc124f4f2015-09-15 14:41:29 -050089}
90
91do_install_append() {
92 mkdir -p ${D}/${includedir}/db51
93 mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/.
94 mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/.
95 ln -s db51/db.h ${D}/${includedir}/db.h
96 ln -s db51/db_cxx.h ${D}/${includedir}/db_cxx.h
97
98 # The docs end up in /usr/docs - not right.
99 if test -d "${D}/${prefix}/docs"
100 then
101 mkdir -p "${D}/${datadir}"
102 test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
103 mv "${D}/${prefix}/docs" "${D}/${docdir}"
104 fi
105
106 chown -R root:root ${D}
107}
108
109INSANE_SKIP_${PN} = "dev-so"
110INSANE_SKIP_${PN}-cxx = "dev-so"
111
112BBCLASSEXTEND = "native nativesdk"