blob: 3c13c6973fb3a90dd9402b393451c0536ad6e3d2 [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001SUMMARY = "Linux kernel module for Video Code Unit"
2DESCRIPTION = "Out-of-tree VCU decoder, encoder and common kernel modules provider for MPSoC EV devices"
3SECTION = "kernel/modules"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eb723b61539feef013de476e68b5c50a"
6
7XILINX_VCU_VERSION = "1.0.0"
Brad Bishop754b8fa2019-08-20 09:16:20 -04008XILINX_RELEASE_VERSION = "v2019.1"
Brad Bishop286d45c2018-10-02 15:21:57 -04009PV = "${XILINX_VCU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
10
11S = "${WORKDIR}/git"
12
Brad Bishop754b8fa2019-08-20 09:16:20 -040013BRANCH ?= "master-rel-2019.1"
Brad Bishop286d45c2018-10-02 15:21:57 -040014REPO ?= "git://github.com/xilinx/vcu-modules.git;protocol=https"
Brad Bishop754b8fa2019-08-20 09:16:20 -040015SRCREV ?= "13a8e5b3f614d94081481a808aa8d4bd00b26d76"
Brad Bishop286d45c2018-10-02 15:21:57 -040016
17BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
18SRC_URI = "${REPO};${BRANCHARG}"
19
20inherit module
21
22EXTRA_OEMAKE += "O=${STAGING_KERNEL_BUILDDIR}"
23
24RDEPENDS_${PN} = "vcu-firmware"
25
26COMPATIBLE_MACHINE = "^$"
27COMPATIBLE_MACHINE_zynqmp = "zynqmp"
28
29PACKAGE_ARCH = "${SOC_FAMILY}"