blob: 1b4d97d76243c77eb2708e46214a1a234c55f270 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "LogFS Programs: used to create LogFS file system"
2DESCRIPTION = "\
3LogFS is a Linux log-structured and scalable flash file system, intended \
4for use on large devices of flash memory. It is written by Jörn Engel and \
5in part sponsored by the CE Linux Forum. \
6LogFS is included in the mainline Linux kernel and was introduced in \
7version 2.6.34, released on May 16, 2010."
8HOMEPAGE = "https://github.com/prasad-joshi/logfsprogs"
9SECTION = "base"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://fsck.c;md5=3859dc73da97909ff1d0125e88a27e02"
12DEPENDS = "zlib"
13
Brad Bishop7f28bc52017-12-03 23:42:40 -050014SRC_URI = "git://github.com/prasad-joshi/logfsprogs.git \
15 file://0001-Add-LDFLAGS-to-linker-cmdline.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016 file://0001-btree-Avoid-conflicts-with-libc-namespace-about-setk.patch \
17 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018SRCREV = "45b72c81ce3c6fa17ca19bafc207ea93e76312f4"
19
20S = "${WORKDIR}/git"
21
22EXTRA_OEMAKE = "CC="${CC}" LD="${LD}" AR="${AR}""
23
24do_install () {
25 mkdir -p ${D}${bindir}
26 install -m 0755 ${S}/mklogfs ${D}${bindir}/mklogfs
27}
28
29BBCLASSEXTEND = "native nativesdk"