blob: c41f0eaa60c657fc690d175afc8ce26b25ab3261 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "LogFS Programs: used to create LogFS file system"
2DESCRIPTION = "\
3LogFS is a Linux log-structured and scalable flash file system, intended \
4for use on large devices of flash memory. It is written by Jörn Engel and \
5in part sponsored by the CE Linux Forum. \
6LogFS is included in the mainline Linux kernel and was introduced in \
7version 2.6.34, released on May 16, 2010."
8HOMEPAGE = "https://github.com/prasad-joshi/logfsprogs"
9SECTION = "base"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://fsck.c;md5=3859dc73da97909ff1d0125e88a27e02"
12DEPENDS = "zlib"
13
Brad Bishop7f28bc52017-12-03 23:42:40 -050014SRC_URI = "git://github.com/prasad-joshi/logfsprogs.git \
15 file://0001-Add-LDFLAGS-to-linker-cmdline.patch \
16"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017SRCREV = "45b72c81ce3c6fa17ca19bafc207ea93e76312f4"
18
19S = "${WORKDIR}/git"
20
21EXTRA_OEMAKE = "CC="${CC}" LD="${LD}" AR="${AR}""
22
23do_install () {
24 mkdir -p ${D}${bindir}
25 install -m 0755 ${S}/mklogfs ${D}${bindir}/mklogfs
26}
27
28BBCLASSEXTEND = "native nativesdk"