blob: f90e2344bb1d073c4ec44d0f109ae72c92248c34 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Configuration files for kexecboot"
2DESCRIPTION = "Default icon and boot.cfg for kexecboot linux-as-bootloader."
3SECTION = "base"
4LICENSE = "MIT"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006
7SRC_URI = "file://icon.xpm"
8
9S = "${WORKDIR}"
10
11do_install_prepend () {
12echo '# /boot/boot.cfg - KEXECBOOT configuration file.
13#
14# First kernel stanza.
15# Show this label in kexecboot menu.
16#
17LABEL=${KEXECBOOT_LABEL}
18#
19# Specify full kernel path on target.
20KERNEL=/boot/${KERNEL_IMAGETYPE}
21#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022# Specify which device tree blob to use
23# DTB=/boot/my-own-dtb
24#
Patrick Williamsb48b7b42016-08-17 15:04:38 -050025# Append this tags to the kernel cmdline.
26APPEND=${CMDLINE} ${CMDLINE_DEBUG}
27#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028# Overwrite kernel command line instead of appending to it
29# CMDLINE=console=/dev/tty0 root=/dev/sdb1
30#
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031# Specify optional initrd/initramfs.
32# INITRD=/boot/initramfs.cpio.gz
33#
34# Specify full path for a custom icon for the menu-item.
35# If not set, use device-icons as default (NAND, SD, CF, ...).
36# ICON=/boot/icon.xpm
37#
38# Priority of item in kexecboot menu.
39# Items with highest priority will be shown at top of menu.
40# Default: 0 (lowest, ordered by device ordering)
41# PRIORITY=10
42#
43#
44# Second kernel stanza.
45# LABEL=${KEXECBOOT_LABEL}-test
46# KERNEL=/boot/${KERNEL_IMAGETYPE}-test
47# APPEND=${CMDLINE}
48#' > ${S}/boot.cfg
49}
50do_install () {
51 install -d ${D}/boot
52 install -m 0644 boot.cfg ${D}/boot/boot.cfg
53 install -m 0644 icon.xpm ${D}/boot/icon.xpm
54}
55
56PACKAGE_ARCH = "${MACHINE_ARCH}"
57
58FILES_${PN} += "/boot/*"
59
60CMDLINE ?= ""
61CMDLINE_DEBUG ?= "quiet"
62
63INHIBIT_DEFAULT_DEPS = "1"
64
65# Note: for qvga the label is currently limited to about 24 chars
Brad Bishop6e60e8b2018-02-01 10:27:11 -050066KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO') or d.getVar('DISTRO_VERSION')}-${MACHINE}"