blob: 42ffb17a1f4f5ca69d15aa7dbb90da5dff6df247 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "The dump DAQ test the various inline mode features "
2HOMEPAGE = "http://www.snort.org"
3SECTION = "libs"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f9ce51a65dd738dc1ae631d8b21c40e0"
6
7PARALLEL_MAKE = ""
8
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009DEPENDS = "libpcap libpcre libdnet bison-native"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010
11SRC_URI = "http://fossies.org/linux/misc/daq-${PV}.tar.gz \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012 file://disable-run-test-program-while-cross-compiling.patch \
13 file://0001-correct-the-location-of-unistd.h.patch \
14 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050015
16# these 2 create undeclared dependency on libdnet and libnetfilter-queue from meta-networking
17# this error from test-dependencies script:
18# daq/daq/latest lost dependency on libdnet libmnl libnetfilter-queue libnfnetlink
19#
20# never look to /usr/local lib while cross compiling
21
22EXTRA_OECONF = "--disable-nfq-module --disable-ipq-module --includedir=${includedir} \
Patrick Williamsddad1a12017-02-23 20:36:32 -060023 --with-libpcap-includes=${STAGING_INCDIR} --with-dnet-includes=${STAGING_LIBDIR}"
24
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
Patrick Williamsddad1a12017-02-23 20:36:32 -060026PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050027
28SRC_URI[md5sum] = "2cd6da422a72c129c685fc4bb848c24c"
29SRC_URI[sha256sum] = "b40e1d1273e08aaeaa86e69d4f28d535b7e53bdb3898adf539266b63137be7cb"
30
31inherit autotools
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032
33DISABLE_STATIC = ""
34
35BBCLASSEXTEND = "native"