blob: 67de07b31f96e367f920ecd63ebb4bdb7b5b7187 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "ISC Kea DHCP Server"
2DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS."
3HOMEPAGE = "http://kea.isc.org"
4SECTION = "connectivity"
5LICENSE = "MPL-2.0 & Apache-2.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1666a9c4bb55adbc8939d85643096bd3"
7
8DEPENDS += "kea-native"
9
10SRC_URI = "\
11 http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \
12 file://0003-Makefile.am-update-hooksdir-for-lease_cmds.patch \
13 file://0001-Fix-error-call-of-overloaded-distance-is-ambiguous.patch \
14 file://kea-dhcp4.service \
15 file://kea-dhcp6.service \
16 file://kea-dhcp-ddns.service \
17"
18SRC_URI[md5sum] = "26eedd749101642757d788431605aaa5"
19SRC_URI[sha256sum] = "c0f8ecb93657adfc5ab970c91706754e601084828493f053f159661d21b31128"
20
21inherit autotools systemd
22
23SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service"
24SYSTEMD_AUTO_ENABLE = "disable"
25
26do_configure_prepend_class-target() {
27 mkdir -p ${B}/src/lib/log/compiler/
28 ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler
29}
30
31do_install_append_class-target() {
32 install -d ${D}${systemd_system_unitdir}
33 install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir}
34 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \
35 -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \
36 ${D}${systemd_system_unitdir}/kea-dhcp*service
37}
38
39do_install_append() {
40 rm -rf "${D}${localstatedir}"
41}
42
43PACKAGECONFIG ??= "openssl log4cplus boost"
44
45PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_TARGET}${prefix},,openssl,openssl"
46PACKAGECONFIG[log4cplus] = "--with-log4cplus=${STAGING_DIR_TARGET}${prefix},,log4cplus,log4cplus"
47PACKAGECONFIG[boost] = "--with-boost-include=${STAGING_INCDIR} --with-boost-lib-dir=${STAGING_LIBDIR} --with-boost-libs=-lboost_system,,boost,boost"
48
49FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
50FILES_${PN} += "${libdir}/hooks/*.so"
51
52BBCLASSEXTEND += "native"