blob: a5b16c979fe30b501af8bbc8abe983e2a1c6f84d [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process."
2
3DESCRIPTION = "Plymouth is an application that runs very early in the boot process \
Patrick Williamsddad1a12017-02-23 20:36:32 -06004 (even before the root filesystem is mounted!) that provides a \
5 graphical boot animation while the boot process happens in the background. \
6"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
8HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth"
9SECTION = "base"
10
11LICENSE = "GPLv2+"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
14
15DEPENDS = "libcap libpng cairo dbus udev"
16PROVIDES = "virtual/psplash"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017RPROVIDES_${PN} = "virtual-psplash virtual-psplash-support"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018
Brad Bishop316dfdd2018-06-25 12:45:53 -040019SRC_URI = " \
20 http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.tar.bz2 \
21 file://0001-Make-full-path-to-systemd-tty-ask-password-agent-con.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022 file://0002-Fix-build-with-glibc-2.28.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040023"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024SRC_URI[md5sum] = "ff420994deb7ea203df678df92e7ab7d"
25SRC_URI[sha256sum] = "2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f"
26
Patrick Williamsddad1a12017-02-23 20:36:32 -060027EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation \
28 --with-logo=${LOGO} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040029 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install --with-systemd-tty-ask-password-agent=${base_bindir}/systemd-tty-ask-password-agent', '', d)} \
Patrick Williamsddad1a12017-02-23 20:36:32 -060030"
31
32PACKAGECONFIG ??= "pango initrd"
33PACKAGECONFIG_append_x86 = " drm"
34PACKAGECONFIG_append_x86-64 = " drm"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050035
36PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
37PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
Brad Bishop316dfdd2018-06-25 12:45:53 -040038PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
Patrick Williamsddad1a12017-02-23 20:36:32 -060039PACKAGECONFIG[initrd] = ",,,"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050040
41LOGO ??= "${datadir}/plymouth/bizcom.png"
42
Patrick Williamsb48b7b42016-08-17 15:04:38 -050043inherit autotools pkgconfig systemd
44
Patrick Williamsb48b7b42016-08-17 15:04:38 -050045do_install_append() {
Patrick Williamsddad1a12017-02-23 20:36:32 -060046 # Remove /var/run from package as plymouth will populate it on startup
47 rm -fr "${D}${localstatedir}/run"
48
49 if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
50 rm -rf "${D}${libexecdir}"
51 fi
Patrick Williamsb48b7b42016-08-17 15:04:38 -050052}
53
Patrick Williamsddad1a12017-02-23 20:36:32 -060054PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}"
55PACKAGES =+ "${PN}-set-default-theme"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050056
57FILES_${PN}-initrd = "${libexecdir}/plymouth/*"
58FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme"
59
60FILES_${PN} += "${systemd_unitdir}/system/*"
61FILES_${PN}-dbg += "${libdir}/plymouth/renderers/.debug"
62
63
64RDEPENDS_${PN}-initrd = "bash dracut"
65RDEPENDS_${PN}-set-default-theme = "bash"
66
67SYSTEMD_SERVICE_${PN} = "plymouth-start.service"