blob: 4ad49971ab85c0b0935c3a6db5ea12a48435c87d [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "USB CEC Adaptor communication Library"
2HOMEPAGE = "http://libcec.pulse-eight.com/"
3
4LICENSE = "GPLv2+"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007DEPENDS = "p8platform udev ncurses swig-native python3"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012PV = "4.0.2+gitr${SRCPV}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014SRCREV = "0a97062dd4b196ceeb003ec41841c7a7edc36dd1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015SRC_URI = "git://github.com/Pulse-Eight/libcec.git \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016 file://0001-Explicitly-use-python3-in-pyCecClient.patch"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017
18S = "${WORKDIR}/git"
19
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020inherit cmake pkgconfig
21
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022# Put client tools into a separate package
23PACKAGE_BEFORE_PN += "${PN}-tools"
24FILES_${PN}-tools = "${bindir}"
25RDEPENDS_${PN}-tools = "python3-${BPN}"
26
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027# Create the wrapper for python3
28PACKAGES += "python3-${BPN}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029FILES_python3-${BPN} = "${libdir}/python3* ${bindir}/py*"
30RDEPENDS_${PN} = "python3-core"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031
32# cec-client and xbmc need the .so present to work :(
33FILES_${PN} += "${libdir}/*.so"
34INSANE_SKIP_${PN} = "dev-so"
35
36# Adapter shows up as a CDC-ACM device
37RRECOMMENDS_${PN} = "kernel-module-cdc-acm"