blob: 2a461fc11a65cdb485e1082c51431dd1b7f96477 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "pam-ssh-agent-auth"
2DESCRIPTION = "A PAM module which permits authentication via ssh-agent."
3HOMEPAGE = "http://sourceforge.net/projects/pamsshagentauth/"
4SECTION = "libs"
5LICENSE = "openssl & BSD"
6LIC_FILES_CHKSUM = "file://LICENSE.OpenSSL;md5=8ab01146141ded59b75f8ba7811ed05a \
7 file://OPENSSH_LICENSE;md5=7ae09218173be1643c998a4b71027f9b \
8"
9
10SRC_URI = "http://sourceforge.net/projects/pamsshagentauth/files/pam_ssh_agent_auth/v${PV}/pam_ssh_agent_auth-${PV}.tar.bz2"
11SRC_URI[md5sum] = "8dbe90ab3625e545036333e6f51ccf1d"
12SRC_URI[sha256sum] = "3c53d358d6eaed1b211239df017c27c6f9970995d14102ae67bae16d4f47a763"
13
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014DEPENDS += "libpam openssl10"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015
Brad Bishop316dfdd2018-06-25 12:45:53 -040016inherit distro_features_check
17REQUIRED_DISTRO_FEATURES = "pam"
18
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019# This gets us ssh-agent, which we are almost certain to want.
20#
21RDEPENDS_${PN} += "openssh-misc"
22
23# Kind of unfortunate to have underscores in the name.
24#
25S = "${WORKDIR}/pam_ssh_agent_auth-${PV}"
26
27inherit autotools-brokensep
28
29# Avoid autoreconf. Override the --libexec oe_runconf specifies so that
30# the module is put with the other pam modules. Because it cannot, in general,
31# do a runtime test, configure wants to use rpl_malloc() and rpl_realloc()
32# instead of malloc() and realloc(). We set variables to tell it not to because
33# these functions do not exist.
34#
35do_configure () {
36 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
37 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
38 oe_runconf --without-openssl-header-check --libexecdir=${base_libdir}/security \
39 ac_cv_func_malloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes
40}
41
42# Link with CC. Configure cannot figure out the correct AR.
43#
44do_compile () {
45 oe_runmake LD="${CC}" AR="${AR}"
46}
47
48# This stuff is not any place looked at by default.
49#
50FILES_${PN} += "${base_libdir}/security/pam*"
51FILES_${PN}-dbg += "${base_libdir}/security/.debug"