blob: c77c10551a6254a6568dc7d3fab1048e7f3e9844 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Control and monitor storage systems using S.M.A.R.T"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08002DESCRIPTION = "\
3The smartmontools package contains two utility programs (smartctl \
Brad Bishop316dfdd2018-06-25 12:45:53 -04004and smartd) to control and monitor storage systems using the Self-\
5Monitoring, Analysis and Reporting Technology System (SMART) built \
6into most modern ATA and SCSI hard disks. In many cases, these \
7utilities will provide advanced warning of disk degradation and failure."
8
9HOMEPAGE = "http://smartmontools.sourceforge.net/"
10SECTION = "console/utils"
11
12LICENSE = "GPLv2"
13LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/smartmontools/smartmontools-${PV}.tar.gz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016 file://initd.smartd \
17 file://smartmontools.default \
18 file://smartd.service \
19 file://0001-os_linux.cpp-Use-realpath-BSD-POSIX-instead-of-canon.patch \
20 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040021
22PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'libcap-ng selinux', d)}"
23PACKAGECONFIG[libcap-ng] = "--with-libcap-ng=yes,--with-libcap-ng=no,libcap-ng"
24PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux"
25
26SRC_URI[md5sum] = "9ae2c6e7131cd2813edcc65cbe5f223f"
27SRC_URI[sha256sum] = "51f43d0fb064fccaf823bbe68cf0d317d0895ff895aa353b3339a3b316a53054"
28
29inherit autotools update-rc.d systemd
30
31SYSTEMD_SERVICE_${PN} = "smartd.service"
32SYSTEMD_AUTO_ENABLE = "disable"
33
34do_install_append () {
35 #install the init.d/smartd
36 install -d ${D}${sysconfdir}/init.d
37 install -p -m 0755 ${WORKDIR}/initd.smartd ${D}${sysconfdir}/init.d/smartd
38 install -d ${D}${sysconfdir}/default
39 install -p -m 0644 ${WORKDIR}/smartmontools.default ${D}${sysconfdir}/default/smartmontools
40
41 #install systemd service file
42 install -d ${D}${systemd_unitdir}/system
43 install -m 0644 ${WORKDIR}/smartd.service ${D}${systemd_unitdir}/system
44 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
45 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
46 -e 's,@SBINDIR@,${sbindir},g' \
47 ${D}${systemd_unitdir}/system/smartd.service
48}
49
50INITSCRIPT_NAME = "smartd"
51INITSCRIPT_PARAMS = "start 60 2 3 4 5 . stop 60 0 1 6 ."
52
53RDEPENDS_${PN} += "mailx"