blob: d313fb02d7d32d8e0f6e36895dacaa87a910bdf1 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Libyui is a widget abstraction library providing Qt, GTK and ncurses frontends."
2LICENSE = "LGPLv3"
3LIC_FILES_CHKSUM = "file://COPYING.gpl-3;md5=d32239bcb673463ab874e80d47fae504 \
4 file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \
5 file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
6 "
7
8SRC_URI = "git://github.com/libyui/libyui.git \
Brad Bishop316dfdd2018-06-25 12:45:53 -04009 file://0001-Fix-build-with-clang.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010 file://0001-Use-curly-braces-for-MAKE-variable.patch \
11 file://0001-Use-relative-install-paths-for-CMake.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040012 "
13
14PV = "3.3.3+git"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015SRCREV = "50672da835ec9d52766320a44a2677e08a24c99c"
16SRCREV_FORMAT = "default"
Brad Bishop316dfdd2018-06-25 12:45:53 -040017S = "${WORKDIR}/git"
18
19inherit cmake gettext pkgconfig
20
21DEPENDS += "boost"
22
23BBCLASSEXTEND = "native nativesdk"
24
25do_configure_prepend () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026 (cd ${S} &&
27 ./bootstrap.sh &&
28 cd -)
Brad Bishop316dfdd2018-06-25 12:45:53 -040029}
30
31do_install_append () {
32 if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then
33 mv ${D}/usr/lib64 ${D}/usr/lib
34 fi
35}
36
37do_install_append_class-nativesdk () {
38 mkdir -p ${D}/${base_prefix}
39 mv ${D}/usr ${D}/${base_prefix}
40}
41
42FILES_${PN}-dev = "${libdir}/* ${includedir}/yui*"