blob: f4d21b8f9f99cb05c11d15aa4a59d281e50a789b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "openbox Window Manager"
2SECTION = "x11/wm"
3DEPENDS = "glib-2.0 pango libxml2 virtual/libx11 libcroco librsvg gdk-pixbuf"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7SRC_URI = " \
8 http://icculus.org/openbox/releases/openbox-${PV}.tar.gz \
9 file://0001-Makefile.am-avoid-race-when-creating-autostart-direc.patch \
10"
11
12SRC_URI[md5sum] = "b72794996c6a3ad94634727b95f9d204"
13SRC_URI[sha256sum] = "8b4ac0760018c77c0044fab06a4f0c510ba87eae934d9983b10878483bde7ef7"
14
15inherit autotools gettext update-alternatives pkgconfig distro_features_check
16# depends on virtual/libx11
17REQUIRED_DISTRO_FEATURES = "x11"
18
Brad Bishop316dfdd2018-06-25 12:45:53 -040019ALTERNATIVE_${PN}-core = "x-window-manager x-session-manager"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/openbox"
21ALTERNATIVE_PRIORITY[x-window-manager] = "10"
Brad Bishop316dfdd2018-06-25 12:45:53 -040022ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/openbox-session"
23ALTERNATIVE_PRIORITY[x-session-manager] = "100"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024
25PACKAGECONFIG ??= ""
26PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2"
27PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
28PACKAGECONFIG[xrandr] = "--enable-xrandr,--disable-xrandr,libxrandr"
29PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama"
30PACKAGECONFIG[xcursor] = "--enable-xcursor,--disable-xcursor,libxcursor"
31
32PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome ${PN}-config"
33
34PACKAGES_DYNAMIC += "^${PN}-theme-.*"
35
36python populate_packages_prepend() {
37 theme_dir = d.expand('${datadir}/themes/')
38 theme_name = d.expand('${PN}-theme-%s')
39 do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
40}
41
Brad Bishop316dfdd2018-06-25 12:45:53 -040042FILES_${PN}-core = "${bindir}/openbox ${bindir}/openbox-session ${libdir}/*${SOLIBS}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050043
44FILES_${PN}-lxde += "${datadir}/lxde/ \
45 ${datadir}/lxpanel \
46 ${datadir}/xsessions \
47 ${datadir}/icons"
48
49FILES_${PN}-gnome += " \
Brad Bishop316dfdd2018-06-25 12:45:53 -040050 ${bindir}/openbox-gnome-session \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050051 ${datadir}/gnome \
52 ${datadir}/gnome-session \
53"
54
55FILES_${PN}-config += "${sysconfdir}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080056
57RDEPENDS_${PN} += "${PN}-core ${PN}-config ${PN}-theme-clearlooks python pyxdg"