blob: 3aab65bf5ba3bdc2f80853c1710b24b39dffdeb7 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "UNIX Shell similar to the Korn shell"
2DESCRIPTION = "Zsh is a shell designed for interactive use, although it is also a \
3 powerful scripting language. Many of the useful features of bash, \
4 ksh, and tcsh were incorporated into zsh; many original features were added."
5HOMEPAGE = "http://www.zsh.org"
6SECTION = "base/shell"
7
8LICENSE = "zsh"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=1a4c4cda3e8096d2fd483ff2f4514fec"
10
11DEPENDS = "ncurses bison-native libcap libpcre gdbm groff-native"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz"
14SRC_URI[md5sum] = "dfe156fd69b0d8d1745ecf6d6e02e047"
15SRC_URI[sha256sum] = "957bcdb2c57f64c02f673693ea5a7518ef24b6557aeb3a4ce222cefa6d74acc9"
16
17inherit autotools gettext update-alternatives
18
19EXTRA_OECONF = " \
20 --bindir=${base_bindir} \
21 --enable-etcdir=${sysconfdir} \
22 --enable-fndir=${datadir}/${PN}/${PV}/functions \
23 --enable-site-fndir=${datadir}/${PN}/site-functions \
24 --with-term-lib='ncursesw ncurses' \
25 --with-tcsetpgrp \
26 --enable-cap \
27 --enable-multibyte \
28 --disable-gdbm \
29 --disable-dynamic \
30 zsh_cv_shared_environ=yes \
31"
32
33# Configure respects --bindir from EXTRA_OECONF, but then Src/Makefile will read bindir from environment
34export bindir="${base_bindir}"
35
36EXTRA_OEMAKE = "-e MAKEFLAGS="
37
38ALTERNATIVE_${PN} = "sh"
39ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
40ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}"
41ALTERNATIVE_PRIORITY = "100"
42
43export AUTOHEADER = "true"
44
45do_configure () {
46 gnu-configize --force ${S}
47 oe_runconf
48}
49
50do_install_append () {
51 rm -fr ${D}/usr/share
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080052 rmdir --ignore-fail-on-non-empty ${D}/usr
Brad Bishop316dfdd2018-06-25 12:45:53 -040053}
54
55pkg_postinst_${PN} () {
56 touch $D${sysconfdir}/shells
57 grep -q "bin/zsh" $D${sysconfdir}/shells || echo /bin/zsh >> $D${sysconfdir}/shells
58 grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
59}
60
61FILES_${PN}-dbg += "\
62 ${libdir}/${PN}/${PV}/${PN}/.debug/*.so \
63 ${libdir}/${PN}/${PV}/${PN}/db/.debug/*.so \
64 ${libdir}/${PN}/${PV}/${PN}/net/.debug/*.so \
65"