blob: b768553323664245a4447947a3d26f9e09c5498e [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Default display timings and resolutions for fbset"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://users.telenet.be/geertu/Linux/fbdev/"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05003LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6PV = "0.1.0"
7PR = "r6"
8
9SRC_URI = "file://fb.modes"
10S = "${WORKDIR}"
11
12do_install() {
13 install -d ${D}${sysconfdir}
14 install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}
15}
16
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017# fb.modes file is MACHINE_ARCH, base.bbclass correctly changes it to MACHINE_ARCH, but too late for allarch.bbclass
18# to disable "all" behavior (found when comparing qemuarm and qemux86 signatures)
19PACKAGE_ARCH = "${MACHINE_ARCH}"
20
21CONFFILES_${PN} = "${sysconfdir}/fb.modes"