blob: 548d2c5788a3e1ac0acbf3d6e81272cd11ede0f3 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.bitbucket.org/"
9
10SECTION = "libs"
11LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=07384b3aa2e0d39afca0d6c40286f545"
13
14DEPENDS = "freetype libpng jpeg zlib tiff"
15
16SRC_URI = "git://github.com/libgd/libgd.git;branch=GD-2.2 \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017 file://0001-annotate.c-gdft.c-Replace-strncpy-with-memccpy-to-fi.patch \
18 file://CVE-2018-1000222.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040019 "
20
21SRCREV = "8255231b68889597d04d451a72438ab92a405aba"
22
23S = "${WORKDIR}/git"
24
25inherit autotools binconfig gettext pkgconfig
26
27EXTRA_OECONF += " --disable-rpath \
28 --with-jpeg=${STAGING_LIBDIR}/.. \
29 --with-freetype=yes \
30 --without-fontconfig \
31 --without-webp \
32 --without-xpm \
33 --without-x \
34 "
35
36EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
37
38do_install_append() {
39 # cleanup buildpaths from gdlib.pc
40 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
41}
42
43PACKAGES += "${PN}-tools"
44
45FILES_${PN} = "${libdir}/lib*${SOLIBS}"
46FILES_${PN}-tools = "${bindir}/*"
47
48PROVIDES += "${PN}-tools"
49RPROVIDES_${PN}-tools = "${PN}-tools"
50RDEPENDS_${PN}-tools = "perl perl-module-strict"