blob: 8c84cb376f6ad96acb20dc424bd052d9ee149b66 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A privileged helper for utmp/wtmp updates"
2DESCRIPTION = "\
3This library provides interface for terminal emulators such as \
4screen and xterm to record user sessions to utmp and wtmp files."
5HOMEPAGE = "ftp://ftp.altlinux.org/pub/people/ldv/utempter"
6SECTION = "System Environment/Libraries"
7LICENSE = "GPLv2 & GPLv2+ & LGPLv2 & MIT"
8LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
9
10SRCREV = "3ef74fff310f09e2601e241b9f042cd39d591018"
11PV = "1.1.6-alt2+git${SRCPV}"
12
13SRC_URI = "git://git.altlinux.org/people/ldv/packages/libutempter.git \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014 file://0001-Fix-macro-error.patch \
15 file://libutempter-remove-glibc-assumption.patch \
16 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017
18S = "${WORKDIR}/git/${BPN}"
19
20CFLAGS += "-DLIBEXECDIR=${libexecdir}"
21
22do_compile() {
23 oe_runmake \
24 libdir=${libdir} \
25 libexecdir=${libexecdir}
26}
27
28do_install() {
29 oe_runmake install \
30 DESTDIR=${D} \
31 libdir="${libdir}" \
32 libexecdir="${libexecdir}" \
33 includedir=${includedir} \
34 mandir=${mandir}
35
36 rm -f ${D}${libdir}/*.a
37}
38
39FILES_${PN} = "${libdir}/*.so.*"
40FILES_${PN} += "${libexecdir}/utempter/utempter"
41FILES_${PN}-dbg += "${libexecdir}/utempter/.debug/utempter"