blob: b9b22a316e97837cc67a987dd8468df2c63c9cbe [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Debian's start-stop-daemon utility extracted from the dpkg \
2package"
3LICENSE = "PD"
4LIC_FILES_CHKSUM = "file://utils/start-stop-daemon.c;endline=21;md5=8fbd0497a7d0b01e99820bffcb58e9ad"
5# start-stop-daemon is usually shipped by dpkg
6DEPENDS = "ncurses"
7RCONFLICTS_${PN} = "dpkg"
8
9SRC_URI = " \
10 ${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.xz \
11 file://0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012 file://0001-Add-linux-musleabi-to-ostable.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050013"
14
15SRC_URI[md5sum] = "e48fcfdb2162e77d72c2a83432d537ca"
16SRC_URI[sha256sum] = "07019d38ae98fb107c79dbb3690cfadff877f153b8c4970e3a30d2e59aa66baa"
17
18inherit autotools gettext pkgconfig
19
20S = "${WORKDIR}/dpkg-${PV}"
21
22EXTRA_OECONF = " \
23 --without-bz2 \
24 --without-selinux \
25"
26
27do_install_append () {
28 # remove everything that is not related to start-stop-daemon, since there
29 # is no explicit rule for only installing ssd
30 find ${D} -type f -not -name "*start-stop-daemon*" -exec rm {} \;
31 find ${D} -depth -type d -empty -exec rmdir {} \;
32
33 # support for buggy init.d scripts that refer to an alternative
34 # explicit path to start-stop-daemon
Brad Bishopd7bf8c12018-02-25 22:55:05 -050035 if [ "${base_sbindir}" != "${sbindir}" ]; then
36 mkdir -p ${D}${base_sbindir}
37 ln -sf ${sbindir}/start-stop-daemon ${D}${base_sbindir}/start-stop-daemon
38 fi
Patrick Williamsb48b7b42016-08-17 15:04:38 -050039}