blob: 0183c2e41ae86a900ba7f0c83f8a5fa06bd18968 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \
2TDD and BDD - using C++11, C++14, C++17 and later."
3AUTHOR = "Phil Nash, Martin Horenovsky and others"
4HOMEPAGE = "https://github.com/catchorg/Catch2"
5LICENSE = "BSL-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
7
8SRC_URI = "git://github.com/catchorg/Catch2.git \
9 file://0001-Fix-convert-from-char-on-ARM-build.patch"
10SRCREV = "9e1bdca4667295fcb16265eae00efa8423f07007"
11
12S = "${WORKDIR}/git"
13
14inherit cmake python3native
15
16# Header-only library
17RDEPENDS_${PN}-dev = ""
18RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
19
20do_install_append() {
21 rm ${D}/${datadir}/Catch2/lldbinit
22 rm ${D}/${datadir}/Catch2/gdbinit
23 rmdir ${D}/${datadir}/Catch2/
24}