blob: 5d2ca00ef5cdcd4a1f73717f7163727d889225ed [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
2LICENSE = "AGPL-3.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428"
4HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne"
5
6PV = "1.2+git${SRCPV}"
7SRCREV = "f7a9be46cb90f57459ebd363d24702de0e651034"
8SRC_URI = "git://github.com/liftoff/GateOne.git;branch=master \
9 file://gateone-avahi.service \
10 file://80oe.conf.in \
11 file://gateone.service.in \
12 file://gateone-init.in \
13"
14
15S = "${WORKDIR}/git"
16
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017inherit setuptools python-dir systemd update-rc.d
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019DISTUTILS_INSTALL_ARGS += " \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020 --install-data=${PYTHON_SITEPACKAGES_DIR} \
21 --install-scripts=${bindir} \
22 --skip_init_scripts"
23
24do_install_append() {
25
26 # fix up hardcoded paths
27 for file in gateone.service gateone-init 80oe.conf; do
28 sed -e s:@bindir@:${bindir}:g \
29 -e s:@localstate@:${localstatedir}:g \
30 < ${WORKDIR}/$file.in \
31 > ${WORKDIR}/$file
32 done
Patrick Williamsddad1a12017-02-23 20:36:32 -060033
Patrick Williamsb48b7b42016-08-17 15:04:38 -050034 install -d ${D}${systemd_unitdir}/system
35 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
36
37 install -d ${D}${sysconfdir}/init.d
38 install -m 0755 ${WORKDIR}/gateone-init ${D}${sysconfdir}/init.d/gateone
Patrick Williamsddad1a12017-02-23 20:36:32 -060039
Patrick Williamsb48b7b42016-08-17 15:04:38 -050040 install -m 0755 -d ${D}${sysconfdir}/avahi/services/
41 install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/
42
43 install -m 0755 -d ${D}${sysconfdir}/gateone/conf.d/
44 install -m 0644 ${WORKDIR}/80oe.conf ${D}${sysconfdir}/gateone/conf.d/80oe.conf
45
46 install -d ${D}${localstatedir}/lib/gateone
47}
48
49FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}"
50RDEPENDS_${PN} = "mime-support \
51 openssh-ssh \
52 python-compression \
53 python-contextlib \
54 python-crypt \
55 python-datetime \
56 python-email \
57 python-fcntl \
58 python-futures \
59 python-html \
60 python-imaging \
61 python-io \
62 python-json \
63 python-logging \
64 python-misc \
65 python-multiprocessing \
66 python-netclient \
67 python-pkgutil \
68 python-pyopenssl \
69 python-re \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050070 python-setuptools \
71 python-shell \
72 python-simplejson \
73 python-subprocess \
74 python-syslog \
75 python-terminal \
76 python-textutils \
77 python-tornado \
78 python-unixadmin \
79 python-xml \
80 python-html5lib \
81 bash \
82"
83
84SYSTEMD_SERVICE_${PN} = "gateone.service"
85INITSCRIPT_NAME = "gateone"