blob: b2401b93ce50cd42ee5cd768955a400f7f37876e [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Script to properly configure BT-HCI on Raspberry Pi"
2HOMEPAGE = "https://github.com/RPi-Distro/pi-bluetooth"
3SECTION = "kernel"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "\
6 file://debian/copyright;md5=6af8de3c8ee71f8e91e9b22f84ff2022 \
7"
8
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009SRC_URI = "\
10 git://github.com/RPi-Distro/pi-bluetooth \
11 file://0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch \
12"
13SRCREV = "2e1a393955910aea67bbf3c921be35a66e8a8fbe"
14PV = "1.1+git${SRCPV}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015
16S = "${WORKDIR}/git"
17
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018# hciuart.service replaces what was brcm43438.service
19inherit systemd
20SYSTEMD_SERVICE_${PN} = "\
21 hciuart.service \
22 bthelper@.service \
23"
24
Brad Bishop316dfdd2018-06-25 12:45:53 -040025inherit allarch
26
27do_install() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028 install -d ${D}${sysconfdir}/udev/rules.d
29 install -m 0644 ${S}/lib/udev/rules.d/* ${D}${sysconfdir}/udev/rules.d
30
Brad Bishop316dfdd2018-06-25 12:45:53 -040031 install -d ${D}${bindir}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032 install -m 0755 ${S}/usr/bin/bthelper ${D}${bindir}
Brad Bishop316dfdd2018-06-25 12:45:53 -040033 install -m 0755 ${S}/usr/bin/btuart ${D}${bindir}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034
35 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
36 install -d ${D}${systemd_system_unitdir}
37 install -m 0644 ${S}/debian/pi-bluetooth.bthelper@.service ${D}${systemd_system_unitdir}/bthelper@.service
38 install -m 0644 ${S}/debian/pi-bluetooth.hciuart.service ${D}${systemd_system_unitdir}/hciuart.service
39 fi
Brad Bishop316dfdd2018-06-25 12:45:53 -040040}
41
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042FILES_${PN} = "\
43 ${bindir} \
44 ${sysconfdir} \
45 ${systemd_unitdir}/system \
46"