blob: 71e0adcd4f3b6a464aacaaa7240106f7d09275ad [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
Brad Bishop3a5fbf52017-12-04 02:17:07 -05003SRC_URI_append_rpi = " \
4 file://xorg.conf.d/98-pitft.conf \
5 file://xorg.conf.d/99-calibration.conf \
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006"
Patrick Williams8b8bc412016-08-17 15:02:23 -05007do_install_append_rpi () {
Brad Bishop3a5fbf52017-12-04 02:17:07 -05008 PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
9 if [ "${PITFT}" = "1" ]; then
10 install -d ${D}/${sysconfdir}/X11/xorg.conf.d/
11 install -m 0644 ${WORKDIR}/xorg.conf.d/98-pitft.conf ${D}/${sysconfdir}/X11/xorg.conf.d/
12 install -m 0644 ${WORKDIR}/xorg.conf.d/99-calibration.conf ${D}/${sysconfdir}/X11/xorg.conf.d/
13 fi
Patrick Williams8b8bc412016-08-17 15:02:23 -050014}
Brad Bishop316dfdd2018-06-25 12:45:53 -040015
Patrick Williams8b8bc412016-08-17 15:02:23 -050016FILES_${PN}_rpi += "${sysconfdir}/X11/xorg.conf ${sysconfdir}/X11/xorg.conf.d/*"