blob: baa21aeae13ba6f29a624ff840a9b623327973f4 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "manage symlinks in /etc/rcN.d"
2HOMEPAGE = "http://github.com/philb/update-rc.d/"
3DESCRIPTION = "update-rc.d is a utility that allows the management of symlinks to the initscripts in the /etc/rcN.d directory structure."
4SECTION = "base"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://update-rc.d;beginline=5;endline=15;md5=148a48321b10eb37c1fa3ee02b940a75"
8
9SRC_URI = "git://git.yoctoproject.org/update-rc.d"
10SRCREV = "22e0692898c3e7ceedc8eb5ff4ec8e0b9c340b2d"
11
12UPSTREAM_CHECK_COMMITS = "1"
13
14S = "${WORKDIR}/git"
15
16inherit allarch
17
18do_compile() {
19}
20
21do_install() {
22 install -d ${D}${sbindir}
23 install -m 0755 ${S}/update-rc.d ${D}${sbindir}/update-rc.d
24}
25
26BBCLASSEXTEND = "native nativesdk"