blob: f1b05da4169158645103363b9ed5e8aeb2c22e0d [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
14 file://dont-depend-on-help2man.patch.patch \
15 file://0001-src-local.mk-fix-parallel-issue.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050016 file://add-with-bisonlocaledir.patch \
Khem Raj2429c7e2018-08-06 15:57:04 -070017 file://gnulib.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018"
19
20# No point in hardcoding path to m4, just use PATH
21EXTRA_OECONF += "M4=m4"
22
23SRC_URI[md5sum] = "c342201de104cc9ce0a21e0ad10d4021"
24SRC_URI[sha256sum] = "a72428c7917bdf9fa93cb8181c971b6e22834125848cf1d03ce10b1bb0716fe1"
25
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026inherit autotools gettext texinfo
Brad Bishop316dfdd2018-06-25 12:45:53 -040027
28# The automatic m4 path detection gets confused, so force the right value
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029acpaths = "-I ${S}/m4"
30
31do_compile_prepend() {
32 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
33}
34
35do_install_append_class-native() {
36 create_wrapper ${D}/${bindir}/bison \
37 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
38}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080039do_install_append_class-nativesdk() {
40 create_wrapper ${D}/${bindir}/bison \
41 BISON_PKGDATADIR=${datadir}/bison
42}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043BBCLASSEXTEND = "native nativesdk"