blob: 29cb231f36cfadffed478b0b3723fab14cba04c5 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "File synchronization tool"
2HOMEPAGE = "http://rsync.samba.org/"
3BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
4SECTION = "console/network"
Brad Bishop316dfdd2018-06-25 12:45:53 -04005# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
6LICENSE = "GPLv3+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009DEPENDS = "popt"
10
11SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
12 file://rsyncd.conf \
13 file://makefile-no-rebuild.patch \
14"
15
16SRC_URI[md5sum] = "1581a588fde9d89f6bc6201e8129afaf"
17SRC_URI[sha256sum] = "55cc554efec5fdaad70de921cd5a5eeb6c29a95524c715f3bbf849235b0800c0"
18
19inherit autotools
20
Brad Bishop316dfdd2018-06-25 12:45:53 -040021PACKAGECONFIG ??= "acl attr \
22 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
23"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024
Brad Bishop316dfdd2018-06-25 12:45:53 -040025PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
26PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
Brad Bishop316dfdd2018-06-25 12:45:53 -040028
29# By default, if crosscompiling, rsync disables a number of
30# capabilities, hardlinking symlinks and special files (i.e. devices)
31CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
32
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033EXTRA_OEMAKE = 'STRIP=""'
34
Brad Bishop316dfdd2018-06-25 12:45:53 -040035# rsync 3.0 uses configure.sh instead of configure, and
36# makefile checks the existence of configure.sh
37do_configure_prepend () {
38 rm -f ${S}/configure ${S}/configure.sh
39}
40
41do_configure_append () {
42 cp -f ${S}/configure ${S}/configure.sh
43}
44
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080045do_install_append() {
46 install -d ${D}${sysconfdir}
47 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
48}
49
Brad Bishop316dfdd2018-06-25 12:45:53 -040050BBCLASSEXTEND = "native"