blob: 617db6cdd310f75e1eb930388b8173778efe49b3 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require cryptodev.inc
2
3SUMMARY = "A test suite for /dev/crypto device driver"
4
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005DEPENDS += "openssl"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006
7SRC_URI += " \
8file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009file://0001-Port-tests-to-openssl-1.1.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010"
11
12EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" PREFIX="${D}"'
13
14do_compile() {
15 oe_runmake testprogs
16}
17
18do_install() {
19 oe_runmake install_tests
20}
21
22FILES_${PN} = "${bindir}/*"