Kumar Thangavel | 06911e3 | 2021-02-17 12:30:20 +0530 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | SRC_URI += "file://ttyS2.conf" |
| 4 | |
| 5 | SRC_URI_append_yosemitev2 += "file://ttyS0.conf" |
| 6 | SRC_URI_append_yosemitev2 += "file://ttyS1.conf" |
| 7 | SRC_URI_append_yosemitev2 += "file://ttyS3.conf" |
| 8 | |
| 9 | do_install_append() { |
| 10 | |
| 11 | # Install the configurations |
| 12 | install -m 0755 -d ${D}${sysconfdir}/${BPN} |
| 13 | install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/ |
| 14 | |
| 15 | # Remove upstream-provided default configuration |
| 16 | rm -f ${D}${sysconfdir}/${BPN}/ttyVUART0.conf |
| 17 | } |