blob: 96e244876d1fe82565fc2171e9c9ab52cd11ec77 [file] [log] [blame]
Ratan Gupta1baa4da2018-04-24 18:10:36 +05301SUMMARY = "SNMP Manager Configuration"
2DESCRIPTION = "SNMP Manager Configuration."
3HOMEPAGE = "http://github.com/openbmc/phosphor-snmp"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6
7inherit autotools pkgconfig
8inherit pythonnative
9inherit obmc-phosphor-dbus-service
10
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
13
14SRC_URI += "git://github.com/openbmc/phosphor-snmp"
15SRCREV = "3f6e2861d7291deea070336abb829c8538dcc7aa"
16
17DBUS_SERVICE_${PN} += "xyz.openbmc_project.Network.SNMP.service"
18
19DEPENDS += "systemd"
20DEPENDS += "autoconf-archive-native"
21DEPENDS += "sdbusplus sdbusplus-native"
22DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
23DEPENDS += "phosphor-logging"
24DEPENDS += "net-snmp"
25
26RDEPENDS_${PN} += "libsystemd"
27RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
28RDEPENDS_${PN} += "phosphor-logging"
29RDEPENDS_${PN} += "net-snmp-libs"
30
31S = "${WORKDIR}/git"