Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "httplib2 caching for requests" |
| 2 | HOMEPAGE = "https://pypi.org/project/CacheControl/" |
| 3 | LICENSE = "Apache-2.0" |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=12;endline=12;md5=942a721dac34d073453642ffe5fcf546" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 5 | |
| 6 | # On PyPi, this is "CacheControl", rather than "cachecontrol", so we need to |
| 7 | # override PYPI_PACKAGE so fetch succeeds. |
| 8 | PYPI_PACKAGE = "CacheControl" |
| 9 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "9c2e5208ea76ebd9921176569743ddf6d7f3bb4188dbf61806f0f8fc48ecad38" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | RDEPENDS:${PN} += "\ |
| 15 | python3-crypt \ |
| 16 | python3-datetime \ |
| 17 | python3-email \ |
| 18 | python3-lockfile \ |
| 19 | python3-json \ |
| 20 | python3-logging \ |
| 21 | python3-msgpack \ |
| 22 | python3-netclient \ |
| 23 | python3-pickle \ |
| 24 | python3-requests \ |
| 25 | python3-urllib3 \ |
| 26 | python3-mmap \ |
| 27 | " |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |