blob: 47aa9675d8b0ac86773dbbd33a5ef552596aa2c2 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15 file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
16"
17
18DEPENDS = "attr libaio libcap acl openssl zip-native"
19DEPENDS_append_libc-musl = " fts "
20EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
21
22# since ltp contains x86-64 assembler which uses the frame-pointer register,
23# set -fomit-frame-pointer x86-64 to handle cases where optimisation
24# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
25# earlier in CFLAGS, etc.
26CFLAGS_append_x86-64 = " -fomit-frame-pointer"
27
28CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
29CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Brad Bishop96ff1982019-08-19 13:50:42 -040030SRCREV = "ac33ef87f0b9dc56533026435be3ea8c67ce86d2"
Brad Bishop19323692019-04-05 15:28:33 -040031
32SRC_URI = "git://github.com/linux-test-project/ltp.git \
Brad Bishop96ff1982019-08-19 13:50:42 -040033 file://0001-build-Add-option-to-select-libc-implementation.patch \
34 file://0002-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch \
35 file://0003-Check-if-__GLIBC_PREREQ-is-defined-before-using-it.patch \
36 file://0004-guard-mallocopt-with-__GLIBC__.patch \
Brad Bishop96ff1982019-08-19 13:50:42 -040037 file://0006-rt_tgsigqueueinfo-disable-test-on-musl.patch \
38 file://0007-Fix-test_proc_kill-hanging.patch \
39 file://0008-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch \
40 file://0009-open_posix_testsuite-mmap24-2-Relax-condition-a-bit.patch \
41 file://0010-shmctl01-don-t-use-hardcoded-index-0-for-SHM_STAT-te.patch \
42 file://0011-direct_io-diotest4-drop-MAP_FIXED.patch \
43 file://0012-getrlimit03-adjust-a-bit-of-code-to-compatiable-with.patch \
Brad Bishop08902b02019-08-20 09:16:51 -040044 file://0001-Add-configure-time-check-for-getdents-getdents64-API.patch \
45 file://0002-check-for-RES_USE_INET6-during-configure.patch \
Brad Bishopc68388fc2019-08-26 01:33:31 -040046 file://0001-syscalls-tgkill03-wait-for-defunct-tid-to-get-detach.patch \
47 file://0001-ustat02-Fix-EFAULT-in-32bit-compatibility-mode.patch \
Brad Bishop79641f22019-09-10 07:20:22 -040048 file://0001-cve-meltdown.c-Fix-kernel-symbol-finding.patch \
49 file://0001-testcases-use-python3-everywhere-to-run-python-scrip.patch \
50 file://0001-syscall-rt_sigtimedwait01-Fix-wrong-sigset-length-fo.patch \
Brad Bishop00e122a2019-10-05 11:10:57 -040051 file://0001-cve-2017-17052-Avoid-unsafe-exits-in-threads.patch \
Brad Bishop64c979e2019-11-04 13:55:29 -050052 file://0001-overcommit_memory-update-for-mm-fix-false-positive-O.patch \
Brad Bishop1d80a2e2019-11-15 16:35:03 -050053 file://0001-mkswap01.sh-Add-udevadm-trigger-before-swap-verifica.patch \
Brad Bishop19323692019-04-05 15:28:33 -040054 "
55
56S = "${WORKDIR}/git"
57
58inherit autotools-brokensep
59
60TARGET_CC_ARCH += "${LDFLAGS}"
61
62export prefix = "/opt/ltp"
63export exec_prefix = "/opt/ltp"
64
65PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
66EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
67EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite --with-open-posix-testsuite "
68# ltp network/rpc test cases ftbfs when libtirpc is found
69EXTRA_OECONF += " --without-tirpc "
70
71do_install(){
72 install -d ${D}/opt/ltp/
73 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
74
75 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
76 # as it lacks dependency on some perl moudle such as LWP::Simple
77 # And this script previously works as a tool for analyzing failures from LTP
78 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
79 # http://khack.osdl.org to retrieve ltp test results run on
80 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
81 rm -rf ${D}/opt/ltp/bin/STPfailure_report.pl
82
83 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
84 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
85}
86
87RDEPENDS_${PN} = "\
88 acl \
89 at \
90 attr \
91 bash \
92 cpio \
93 cronie \
94 curl \
95 e2fsprogs-mke2fs \
96 expect \
97 file \
98 gawk \
99 gzip \
100 iproute2 \
101 ldd \
102 libaio \
103 logrotate \
104 perl \
Brad Bishop79641f22019-09-10 07:20:22 -0400105 python3-core \
Brad Bishop19323692019-04-05 15:28:33 -0400106 procps \
107 quota \
108 unzip \
109 util-linux \
110 which \
111 tar \
112"
113
114FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/* /opt/ltp/testcases/data/nm01/lib.a /opt/ltp/lib/libmem.a"
115
116# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
117INHIBIT_PACKAGE_STRIP_FILES = "/opt/ltp/testcases/bin/nm01 /opt/ltp/testcases/bin/ldd01"
118INSANE_SKIP_${PN} += "already-stripped staticdev"
119
120# Avoid file dependency scans, as LTP checks for things that may or may not
121# exist on the running system. For instance it has specific checks for
122# csh and ksh which are not typically part of OpenEmbedded systems (but
123# can be added via additional layers.)
124SKIP_FILEDEPS_${PN} = '1'