blob: 71f61b484854071514b58a3198e8d9b7f77c56a3 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
5SECTION = "console/utils"
6DEPENDS = "ncurses glib-2.0 util-linux"
7RDEPENDS_${PN} = "ncurses-terminfo"
8
9SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
10 file://0001-mc-replace-perl-w-with-use-warnings.patch \
Brad Bishop1d80a2e2019-11-15 16:35:03 -050011 file://0001-Add-option-to-control-configure-args.patch \
Brad Bishop19323692019-04-05 15:28:33 -040012 "
Brad Bishop96ff1982019-08-19 13:50:42 -040013SRC_URI[md5sum] = "152927ac29cf0e61d7d019f261bb7d89"
14SRC_URI[sha256sum] = "238c4552545dcf3065359bd50753abbb150c1b22ec5a36eaa02c82808293267d"
Brad Bishop19323692019-04-05 15:28:33 -040015
16inherit autotools gettext pkgconfig
17
18#
19# Both Samba (smb) and sftp require package delivered from meta-openembedded
20#
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba,"
23PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
24
Brad Bishop1d80a2e2019-11-15 16:35:03 -050025EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-configure-args"
Brad Bishop19323692019-04-05 15:28:33 -040026
27CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
Brad Bishop1d80a2e2019-11-15 16:35:03 -050028CACHED_CONFIGUREVARS += "ac_cv_path_PYTHON='/usr/bin/env python'"
29CACHED_CONFIGUREVARS += "ac_cv_path_GREP='/usr/bin/env grep'"
Brad Bishop19323692019-04-05 15:28:33 -040030
31do_install_append () {
32 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
33
34 rm ${D}${libexecdir}/mc/extfs.d/s3+ ${D}${libexecdir}/mc/extfs.d/uc1541
35}
36
37PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish"
38
39SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
40FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
41 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
42 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
43 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
44 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
45 ${libexecdir}/mc/extfs.d/uzip"
46RDEPENDS_${BPN}-helpers-perl = "perl"
47
48SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts"
49FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
50
51SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts"
52FILES_${BPN}-fish = "${libexecdir}/mc/fish"